Can i use Cloud Firestore triggers in Cloud Functions with node 8?

To have an answer to this question, you are receiving an error : Node.js v10.0.0 is a minimum requirement because you are using Node.js v8. The Node.js v8 was deprecated on December 31, 2019 and the minimum requirement now is Node.js v10.

Now, if you are now using Node.js version v10 and above, you can’t deploy it if your billing account is disabled or not enabled, why you should enable your billing account?

Because of updates to its underlying architecture planned for August 17, 2020, Cloud Functions for Firebase will rely on some additional paid Google services: Cloud Build, Container Registry, and Cloud Storage. These architecture updates will apply for functions deployed to the Node.js 10 runtime.

CLICK HERE to find out more related problems solutions.

Leave a Comment

Your email address will not be published.

Scroll to Top