an argument for invokemiddleware was not provided

This answer was taken from the community Slack channel

As per-the documentation (permalink), modifying src/sequence.ts is only meant for the now-deprecated Action-based Sequences, and not required for Middleware-based Sequences which are used by default on newly-generated LoopBack 4 projects.

How to identify the “sequence type”

The class signature will hint at which sequence type is being used:

// Action-based sequence
class MySequence extends DefaultSequence {/* ... */}

// Middleware-based Sequence
class MySequence extends MiddlewareSequence {/* ... */}

CLICK HERE to find out more related problems solutions.

Leave a Comment

Your email address will not be published.

Scroll to Top